VS:GetComponentNetArea: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentNetArea(object:HANDLE; componentIndex:INTEGER) : REAL;
FUNCTION GetComponentNetArea(obj:HANDLE; componentIndex:INTEGER) : REAL;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentNetArea(object, componentIndex):
def vs.GetComponentNetArea(obj, componentIndex):
     return REAL
     return REAL
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 19:49, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the net area of a component in an object.

FUNCTION GetComponentNetArea(
obj :HANDLE;
componentIndex :INTEGER) : REAL;
def vs.GetComponentNetArea(obj, componentIndex):
    return REAL

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.

Return Value

The net area of the component.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:GetComponentNetVolume

VS Functions: [[VS:GetComponentNetVolume]]