VS:GetComponentName

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the name of a component in an object.

FUNCTION GetComponentName(
object :HANDLE;
componentIndex :INTEGER) : STRING;
def vs.GetComponentName(object, componentIndex):
    return STRING

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.

Return Value

The name of the component.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentName

VS Functions: [[VS:SetComponentName]]