VS:GetComponentName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentName(object:HANDLE; componentIndex:INTEGER) : STRING;
FUNCTION GetComponentName(obj:HANDLE; componentIndex:INTEGER) : STRING;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentName(object, componentIndex):
def vs.GetComponentName(obj, componentIndex):
     return STRING
     return STRING
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Revision as of 19:49, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the name of a component in an object.

FUNCTION GetComponentName(
obj :HANDLE;
componentIndex :INTEGER) : STRING;
def vs.GetComponentName(obj, componentIndex):
    return STRING

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.

Return Value

The name of the component.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentName

VS Functions: [[VS:SetComponentName]]