VS:GetComponentName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Shorten OBJECT, reserved word)
No edit summary
 
Line 30: Line 30:
componentIndex
componentIndex
INTEGER
INTEGER
The index of the component.
The index of the component, 1-based.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 12:03, 20 March 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the name of a component in an object.

FUNCTION GetComponentName(
obj :HANDLE;
componentIndex :INTEGER) : STRING;
def vs.GetComponentName(obj, componentIndex):
    return STRING

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component, 1-based.

Return Value

The name of the component.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentName

VS Functions: [[VS:SetComponentName]]