VS:GetComponentMaterial

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the material of a component in an object.

FUNCTION GetComponentMaterial(
object :HANDLE;
componentIndex :INTEGER;
VAR material :LONGINT) : BOOLEAN;
def vs.GetComponentMaterial(object, componentIndex):
    return (BOOLEAN, material)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
material LONGINT Returns the material of the component.

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:SetComponentMaterial

VS Functions: [[VS:SetComponentMaterial]]