VS:GetComponentMaterial: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the material of a component in an object.

FUNCTION GetComponentMaterial(
object :HANDLE;
componentIndex :INTEGER;
VAR material :LONGINT) : BOOLEAN;
def vs.GetComponentMaterial(object, componentIndex):
    return (BOOLEAN, material)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
material LONGINT Returns the material of the component.

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:SetComponentMaterial

VS Functions: [[VS:SetComponentMaterial]]