VS:GetComponentFollowTopWallPeaks

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the follow top wall peaks flag of a component in an object.

FUNCTION GetComponentFollowTopWallPeaks(
obj :HANDLE;
componentIndex :INTEGER;
VAR followTopWallPeaks :BOOLEAN) : BOOLEAN;
def vs.GetComponentFollowTopWallPeaks(obj, componentIndex):
    return (BOOLEAN, followTopWallPeaks)

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
followTopWallPeaks BOOLEAN Returns whether or not the component is following top wall peaks.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentFollowTopWallPeaks

VS Functions: [[VS:SetComponentFollowTopWallPeaks]]