VS:GetComponentFollowTopWallPeaks: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentFollowTopWallPeaks(object:HANDLE; componentIndex:INTEGER; VAR followTopWallPeaks:BOOLEAN) : BOOLEAN;
FUNCTION GetComponentFollowTopWallPeaks(obj:HANDLE; componentIndex:INTEGER; VAR followTopWallPeaks:BOOLEAN) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentFollowTopWallPeaks(object, componentIndex):
def vs.GetComponentFollowTopWallPeaks(obj, componentIndex):
     return (BOOLEAN, followTopWallPeaks)
     return (BOOLEAN, followTopWallPeaks)
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Latest revision as of 19:47, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the follow top wall peaks flag of a component in an object.

FUNCTION GetComponentFollowTopWallPeaks(
obj :HANDLE;
componentIndex :INTEGER;
VAR followTopWallPeaks :BOOLEAN) : BOOLEAN;
def vs.GetComponentFollowTopWallPeaks(obj, componentIndex):
    return (BOOLEAN, followTopWallPeaks)

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
followTopWallPeaks BOOLEAN Returns whether or not the component is following top wall peaks.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentFollowTopWallPeaks

VS Functions: [[VS:SetComponentFollowTopWallPeaks]]