VS:GetComponentFollowBottomWallPeaks

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the follow bottom wall peaks flag of a component in an object.

FUNCTION GetComponentFollowBottomWallPeaks(
obj :HANDLE;
componentIndex :INTEGER;
VAR followBottomWallPeaks :BOOLEAN) : BOOLEAN;
def vs.GetComponentFollowBottomWallPeaks(obj, componentIndex):
    return (BOOLEAN, followBottomWallPeaks)

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
followBottomWallPeaks BOOLEAN Returns whether or not the component is following bottom wall peaks.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentFollowBottomWallPeaks

VS Functions: [[VS:SetComponentFollowBottomWallPeaks]]