VS:GetComponentFillColors: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentFillColors(object:HANDLE; componentIndex:INTEGER; VAR fillForeColor:INTEGER; VAR fillBackColor:INTEGER) : BOOLEAN;
FUNCTION GetComponentFillColors(obj:HANDLE; componentIndex:INTEGER; VAR fillForeColor:INTEGER; VAR fillBackColor:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentFillColors(object, componentIndex):
def vs.GetComponentFillColors(obj, componentIndex):
     return (BOOLEAN, fillForeColor, fillBackColor)
     return (BOOLEAN, fillForeColor, fillBackColor)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 19:46, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the fore and back fill colors of a component in an object.

FUNCTION GetComponentFillColors(
obj :HANDLE;
componentIndex :INTEGER;
VAR fillForeColor :INTEGER;
VAR fillBackColor :INTEGER) : BOOLEAN;
def vs.GetComponentFillColors(obj, componentIndex):
    return (BOOLEAN, fillForeColor, fillBackColor)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fillForeColor INTEGER Returns the fore color of the fill.
fillBackColor INTEGER Returns the back color of the fill.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentFillColors

VS Functions: [[VS:SetComponentFillColors]]