VS:GetComponentFill

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the fill of a component in an object.

FUNCTION GetComponentFill(
object :HANDLE;
componentIndex :INTEGER;
VAR fill :LONGINT) : BOOLEAN;
def vs.GetComponentFill(object, componentIndex):
    return (BOOLEAN, fill)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fill LONGINT Returns the fill of the component. Positive values for patterns, negative ref numbers for hatches.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:SetComponentFill

VS Functions: [[VS:SetComponentFill]]