VS:GetComponentFill

From Vectorworks Developer
Revision as of 19:45, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the fill of a component in an object.

FUNCTION GetComponentFill(
obj :HANDLE;
componentIndex :INTEGER;
VAR fill :LONGINT) : BOOLEAN;
def vs.GetComponentFill(obj, componentIndex):
    return (BOOLEAN, fill)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fill LONGINT Returns the fill of the component. Positive values for patterns, negative ref numbers for hatches.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentFill

VS Functions: [[VS:SetComponentFill]]