VS:GetComponentFill: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentFill(object:HANDLE; componentIndex:INTEGER; VAR fill:LONGINT) : BOOLEAN;
FUNCTION GetComponentFill(obj:HANDLE; componentIndex:INTEGER; VAR fill:LONGINT) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentFill(object, componentIndex):
def vs.GetComponentFill(obj, componentIndex):
     return (BOOLEAN, fill)
     return (BOOLEAN, fill)
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 54: Line 54:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Latest revision as of 19:45, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the fill of a component in an object.

FUNCTION GetComponentFill(
obj :HANDLE;
componentIndex :INTEGER;
VAR fill :LONGINT) : BOOLEAN;
def vs.GetComponentFill(obj, componentIndex):
    return (BOOLEAN, fill)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
fill LONGINT Returns the fill of the component. Positive values for patterns, negative ref numbers for hatches.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:SetComponentFill

VS Functions: [[VS:SetComponentFill]]