VS:GetComponentClass

From Vectorworks Developer
Revision as of 19:44, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the class of a component in an object.

FUNCTION GetComponentClass(
obj :HANDLE;
componentIndex :INTEGER;
VAR componentClass :LONGINT) : BOOLEAN;
def vs.GetComponentClass(obj, componentIndex):
    return (BOOLEAN, componentClass)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
componentClass LONGINT Returns the class of the component.

Remarks

To get the name of the class, use VS:Index2Name, not VS:ClassList to convert componentClass to a STRING.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentClass

VS Functions: [[VS:SetComponentClass]]