VS:GetComponentClass: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the class of a component in an object.

FUNCTION GetComponentClass(
object :HANDLE;
componentIndex :INTEGER;
VAR componentClass :LONGINT) : BOOLEAN;
def vs.GetComponentClass(object, componentIndex):
    return (BOOLEAN, componentClass)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
componentClass LONGINT Returns the class of the component.

Remarks

To get the name of the class, use VS:Index2Name, not VS:ClassList to convert componentClass to a STRING.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentClass

VS Functions: [[VS:SetComponentClass]]