VS:GetComponentClass: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentClass(object:HANDLE; componentIndex:INTEGER; VAR componentClass:LONGINT) : BOOLEAN;
FUNCTION GetComponentClass(obj:HANDLE; componentIndex:INTEGER; VAR componentClass:LONGINT) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentClass(object, componentIndex):
def vs.GetComponentClass(obj, componentIndex):
     return (BOOLEAN, componentClass)
     return (BOOLEAN, componentClass)
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.

Latest revision as of 19:44, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the class of a component in an object.

FUNCTION GetComponentClass(
obj :HANDLE;
componentIndex :INTEGER;
VAR componentClass :LONGINT) : BOOLEAN;
def vs.GetComponentClass(obj, componentIndex):
    return (BOOLEAN, componentClass)

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component.
componentClass LONGINT Returns the class of the component.

Remarks

To get the name of the class, use VS:Index2Name, not VS:ClassList to convert componentClass to a STRING.

Version

Availability: from VectorWorks 2008

See Also

VS Functions:

VS:SetComponentClass

VS Functions: [[VS:SetComponentClass]]