VS:GetComponentAutoBoundEdgeOffset

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the auto-bound edge offset of a component in an object.

FUNCTION GetComponentAutoBoundEdgeOffset(
object :HANDLE;
componentIndex :INTEGER;
VAR autoBoundEdgeOffset :INTEGER) : BOOLEAN;
def vs.GetComponentAutoBoundEdgeOffset(object, componentIndex):
    return (BOOLEAN, autoBoundEdgeOffset)

Parameters

object HANDLE The object. Can be a slab, Slab Style, or the Slab Preferences.
componentIndex INTEGER The index of the component.
autoBoundEdgeOffset INTEGER Returns the auto-bound edge offset. 0 - Inner face, 1 - Outer face of inner component, 2 - Inner face of core, 3 - Center of core, 4 - Outer face of core, 5 - Inner face of outer component, 6 - Outer face

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentAutoBoundEdgeOffset

VS Functions: [[VS:SetComponentAutoBoundEdgeOffset]]