VS:GetComponentAutoBoundEdgeOffset

From Vectorworks Developer
Revision as of 19:43, 10 February 2016 by CBM-c- (talk | contribs) (Shorten OBJECT, reserved word)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the auto-bound edge offset of a component in an object.

FUNCTION GetComponentAutoBoundEdgeOffset(
obj :HANDLE;
componentIndex :INTEGER;
VAR autoBoundEdgeOffset :INTEGER) : BOOLEAN;
def vs.GetComponentAutoBoundEdgeOffset(obj, componentIndex):
    return (BOOLEAN, autoBoundEdgeOffset)

Parameters

obj HANDLE The object. Can be a slab, Slab Style, or the Slab Preferences.
componentIndex INTEGER The index of the component.
autoBoundEdgeOffset INTEGER Returns the auto-bound edge offset. 0 - Inner face, 1 - Outer face of inner component, 2 - Inner face of core, 3 - Center of core, 4 - Outer face of core, 5 - Inner face of outer component, 6 - Outer face

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentAutoBoundEdgeOffset

VS Functions: [[VS:SetComponentAutoBoundEdgeOffset]]