VS:GetComponentAutoBoundEdgeOffset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetComponentAutoBoundEdgeOffset(object:HANDLE; componentIndex:INTEGER; VAR autoBoundEdgeOffset:INTEGER) : BOOLEAN;
FUNCTION GetComponentAutoBoundEdgeOffset(obj:HANDLE; componentIndex:INTEGER; VAR autoBoundEdgeOffset:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetComponentAutoBoundEdgeOffset(object, componentIndex):
def vs.GetComponentAutoBoundEdgeOffset(obj, componentIndex):
     return (BOOLEAN, autoBoundEdgeOffset)
     return (BOOLEAN, autoBoundEdgeOffset)
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a  slab, Slab Style, or the Slab Preferences.
The object. Can be a  slab, Slab Style, or the Slab Preferences.

Latest revision as of 19:43, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the auto-bound edge offset of a component in an object.

FUNCTION GetComponentAutoBoundEdgeOffset(
obj :HANDLE;
componentIndex :INTEGER;
VAR autoBoundEdgeOffset :INTEGER) : BOOLEAN;
def vs.GetComponentAutoBoundEdgeOffset(obj, componentIndex):
    return (BOOLEAN, autoBoundEdgeOffset)

Parameters

obj HANDLE The object. Can be a slab, Slab Style, or the Slab Preferences.
componentIndex INTEGER The index of the component.
autoBoundEdgeOffset INTEGER Returns the auto-bound edge offset. 0 - Inner face, 1 - Outer face of inner component, 2 - Inner face of core, 3 - Center of core, 4 - Outer face of core, 5 - Inner face of outer component, 6 - Outer face

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:SetComponentAutoBoundEdgeOffset

VS Functions: [[VS:SetComponentAutoBoundEdgeOffset]]