VS:GetCompWallAssBound

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the wall associated bound of a component in an object.

FUNCTION GetCompWallAssBound(
object :HANDLE;
componentIndex :INTEGER;
VAR wallAssociatedBound :INTEGER) : BOOLEAN;
def vs.GetCompWallAssBound(object, componentIndex):
    return (BOOLEAN, wallAssociatedBound)

Parameters

object HANDLE The object. Can be a roof face, roof, Roof Style, or the Roof Preferences.
componentIndex INTEGER The index of the component.
wallAssociatedBound INTEGER Returns the wall associated bound of the component. 0 - Inner face 1 - Outer face of inner component 2 - Inner face of core 3 - Center of core 4 - Outer face of core 5 - Inner face of outer component 6 - Roof edge 7 - Roof axis line

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompWallAssBound

VS Functions: [[VS:SetCompWallAssBound]]