VS:GetCompUseClassRPS

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class pen style for right pen flag of a component in an object.

FUNCTION GetCompUseClassRPS(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassPenStyleForRightPen :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassRPS(object, componentIndex):
    return (BOOLEAN, useClassPenStyleForRightPen)

Parameters

object HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
useClassPenStyleForRightPen BOOLEAN Returns whether or not the component is using class attributes for its right pen style.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassRPS

VS Functions: [[VS:SetCompUseClassRPS]]