VS:GetCompUseClassRPCl: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 17:43, 16 September 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class pen colors for right pen flag of a component in an object.

FUNCTION GetCompUseClassRPCl(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassPenColorsForRightPen :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassRPCl(object, componentIndex):
    return (BOOLEAN, useClassPenColorsForRightPen)

Parameters

object HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
useClassPenColorsForRightPen BOOLEAN Returns whether or not the component is using class attributes for its right pen colors.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassRPCl

VS Functions: [[VS:SetCompUseClassRPCl]]