VS:GetCompUseClassLPW: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 17:43, 16 September 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class pen weight for left pen flag of a component in an object.

FUNCTION GetCompUseClassLPW(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassPenWeightForLeftPen :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassLPW(object, componentIndex):
    return (BOOLEAN, useClassPenWeightForLeftPen)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassPenWeightForLeftPen BOOLEAN Returns whether or not the component is using class attributes for its left pen weight.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassLPW

VS Functions: [[VS:SetCompUseClassLPW]]