VS:GetCompUseClassLPS

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class pen style for left pen flag of a component in an object.

FUNCTION GetCompUseClassLPS(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassPenStyleForLeftPen :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassLPS(object, componentIndex):
    return (BOOLEAN, useClassPenStyleForLeftPen)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassPenStyleForLeftPen BOOLEAN Returns whether or not the component is using class attributes for its left pen style.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassLPS

VS Functions: [[VS:SetCompUseClassLPS]]