VS:GetCompUseClassLPCl: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 17:43, 16 September 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class pen colors for left pen flag of a component in an object.

FUNCTION GetCompUseClassLPCl(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassPenColorsForLeftPen :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassLPCl(object, componentIndex):
    return (BOOLEAN, useClassPenColorsForLeftPen)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassPenColorsForLeftPen BOOLEAN Returns whether or not the component is using class attributes for its left pen colors.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassLPCl

VS Functions: [[VS:SetCompUseClassLPCl]]