VS:GetCompUseClassFCl

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class fill colors for fill flag of a component in an object.

FUNCTION GetCompUseClassFCl(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassFillColorsForFill :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassFCl(object, componentIndex):
    return (BOOLEAN, useClassFillColorsForFill)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassFillColorsForFill BOOLEAN Returns whether or not the component is using class attributes for its fill colors.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassFCl

VS Functions: [[VS:SetCompUseClassFCl]]