VS:GetCompUseClassASF

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class fill style for alternate section fill flag of a component in an object.

FUNCTION GetCompUseClassASF(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassFillStyleForAlternateSectionFill :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassASF(object, componentIndex):
    return (BOOLEAN, useClassFillStyleForAlternateSectionFill)

Parameters

object HANDLE The object. Can be a roof face, roof, Roof Style, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassFillStyleForAlternateSectionFill BOOLEAN Returns whether or not the component is using class attributes for its alternate section fill.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassASF

VS Functions: [[VS:SetCompUseClassASF]]