VS:GetCompMasterSnaps

From Vectorworks Developer
Revision as of 18:51, 7 December 2020 by Unknown user
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the master snaps of a component in an object.

FUNCTION GetCompMasterSnaps(
object :HANDLE;
componentIndex :INTEGER;
VAR masterSnapOnLeft :BOOLEAN;
VAR masterSnapOnRight :BOOLEAN) : BOOLEAN;
def vs.GetCompMasterSnaps(object, componentIndex):
    return (BOOLEAN, masterSnapOnLeft, masterSnapOnRight)

Parameters

object HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
masterSnapOnLeft BOOLEAN Returns whether or not the component has a master snap on its left.
masterSnapOnRight BOOLEAN Returns whether or not the component has a master snap on its right.

Version

Availability: from Vectorworks 2017

See Also

VS Functions:

VS:SetCompMasterSnaps

VS Functions: [[VS:SetCompMasterSnaps]]