VS:GetCompDatTopOfComp

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the datum is top of component flag of a component in an object.

FUNCTION GetCompDatTopOfComp(
object :HANDLE;
componentIndex :INTEGER;
VAR datumIsTopOfComponent :BOOLEAN) : BOOLEAN;
def vs.GetCompDatTopOfComp(object, componentIndex):
    return (BOOLEAN, datumIsTopOfComponent)

Parameters

object HANDLE The object. Can be a slab, roof face, roof, Slab Style, Roof Style, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
datumIsTopOfComponent BOOLEAN Returns whether or not the datum is the top of the component.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompDatTopOfComp

VS Functions: [[VS:SetCompDatTopOfComp]]