VS:GetCompAltSecFillCl

From Vectorworks Developer
Revision as of 04:44, 5 February 2016 by CBM-c- (talk | contribs) (link to other remarks)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the alternate section fill colors of a component in an object.

FUNCTION GetCompAltSecFillCl(
object :HANDLE;
componentIndex :INTEGER;
VAR alternateSectionFillForeColor :INTEGER;
VAR alternateSectionFillBackColor :INTEGER) : BOOLEAN;
def vs.GetCompAltSecFillCl(object, componentIndex):
    return (BOOLEAN, alternateSectionFillForeColor, alternateSectionFillBackColor)

Parameters

object HANDLE The object. Can be a roof face, roof, Roof Style, or the Roof Preferences.
componentIndex INTEGER The index of the component.
alternateSectionFillForeColor INTEGER Returns the alternate section fill fore color of the component.
alternateSectionFillBackColor INTEGER Returns the alternate section fill back color of the component.

Remarks

Orso: (2016.02.03): See remarks under VS:GetCompAltSecFill!

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompAltSecFillCl

VS Functions: [[VS:SetCompAltSecFillCl]]