VS:GetCompAltSecFill

From Vectorworks Developer
Revision as of 09:00, 3 February 2016 by CBM-c- (talk | contribs) (shorten 'object' (reserved word), add remark about the prefs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the alternate section fill of a component in an object.

FUNCTION GetCompAltSecFill(
obj :HANDLE;
componentIndex :INTEGER;
VAR alternateSectionFill :LONGINT) : BOOLEAN;
def vs.GetCompAltSecFill(obj, componentIndex):
    return (BOOLEAN, alternateSectionFill)

Parameters

object HANDLE The object. Can be a roof face, roof, Roof Style, or the Roof Preferences.
componentIndex INTEGER The index of the component.
alternateSectionFill LONGINT Returns the alternate section fill of the component.

Remarks

Orso: (2016.02.03): The Alternate Section fill is used for Roof Style components whose "Section FIll Change Point" is not none, this only applies to Roof Styles. It nevertheless returns the current fill index for Slab and Wall Styles.

Warning
passing NIL will always return the Wall Preferences' component fill! Not the Roof's Preference component alternate fill!

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompAltSecFill

VS Functions: [[VS:SetCompAltSecFill]]