VS:GetClVectorFill

From Vectorworks Developer
Revision as of 21:39, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the name of the hatch pattern setting of the specified class.

The function return value will be TRUE if the class uses a hatch pattern, and will be FALSE if the class does not use a hatch pattern.

FUNCTION GetClVectorFill(
className :STRING;
VAR hatchName :STRING) : BOOLEAN;
def vs.GetClVectorFill(className):
    return (BOOLEAN, hatchName)

Parameters

className STRING Name of class.
hatchName STRING Name of active hatch pattern (if it exists).

Version

Availability: from VectorWorks9.0