VS:GetClPenFore: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the pen foreground color setting of the specified class. The color is returned as the three RGB components of the color. RGB values are in the range of 0~65535.

PROCEDURE GetClPenFore(
className :STRING;
VAR colorRV :LONGINT;
VAR colorGV :LONGINT;
VAR colorBV :LONGINT);
def vs.GetClPenFore(className):
    return (colorRV, colorGV, colorBV)

Parameters

className STRING Name of class.
colorRV LONGINT Returns RGB color component (red).
colorGV LONGINT Returns RGB color component (green).
colorBV LONGINT Returns RGB color component (blue).

Remarks

Returns the pen foreground color setting of the class named className in parameters colorRV, colorGV, and colorBV.

Example

VectorScript

GetClPenFore('Grassy Cover',cRed,cGrn,cBlu);
RGBToColorIndex(cRed,cGrn,cBlu,colorValue);

Python

cRed,cGrn,cBlu = vs.GetClPenFore('Grassy Cover')
colorValue = vs.RGBToColorIndex(cRed,cGrn,cBlu)

Version

Availability: from VectorWorks8.0