VS:GetClPenBack

From Vectorworks Developer
Revision as of 21:39, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the pen background color setting of the specified class. The color is returned as the three RGB components of the color. RGB values are in the range of 0~65535.

PROCEDURE GetClPenBack(
className :STRING;
VAR colorRV :LONGINT;
VAR colorGV :LONGINT;
VAR colorBV :LONGINT);
def vs.GetClPenBack(className):
    return (colorRV, colorGV, colorBV)

Parameters

className STRING Name of class.
colorRV LONGINT Returns RGB color component (red).
colorGV LONGINT Returns RGB color component (green).
colorBV LONGINT Returns RGB color component (blue).

Remarks

Returns the pen background color setting of the class named className in parameters colorRV, colorGV, and colorBV.

Version

Availability: from VectorWorks8.0