VS:GetClFillBack

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fill background color setting of the specified class. The color is returned as the three RGB components of the color. RGB values are in the range of 0~65535.

PROCEDURE GetClFillBack(
className :STRING;
VAR colorRV :LONGINT;
VAR colorGV :LONGINT;
VAR colorBV :LONGINT);
def vs.GetClFillBack(className):
    return (colorRV, colorGV, colorBV)

Parameters

className STRING Name of class.
colorRV LONGINT Returns RGB color component (red).
colorGV LONGINT Returns RGB color component (green).
colorBV LONGINT Returns RGB color component (blue).

Remarks

Returns the fill background color setting of the class named className in parameters colorRV, colorGV, and colorBV.

Example

VectorScript

PROCEDURE Example;
VAR
   cRed, cGrn, cBlu : LONGINT;
   colorValue : INTEGER;
BEGIN
  GetClFillBack('Grassy Cover',cRed,cGrn,cBlu);
  RGBToColorIndex(cRed,cGrn,cBlu,colorValue);
  Message(colorValue);
END;
RUN(Example);

Python

Python


Version

Availability: from VectorWorks8.0