VS:GetClFillBack: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 53: Line 53:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
==== VectorScript ====
<code lang="pas">
<code lang="pas">
GetClFillBack('Grassy Cover',cRed,cGrn,cBlu);
PROCEDURE Example;
RGBToColorIndex(cRed,cGrn,cBlu,colorValue);
VAR
  cRed, cGrn, cBlu : LONGINT;
  colorValue : INTEGER;
BEGIN
  GetClFillBack('Grassy Cover',cRed,cGrn,cBlu);
  RGBToColorIndex(cRed,cGrn,cBlu,colorValue);
  Message(colorValue);
END;
RUN(Example);
</code>
==== Python ====
==== Python ====
<code lang="py">
 
</code>
</code>
</sample>
</sample>

Latest revision as of 19:41, 19 June 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fill background color setting of the specified class. The color is returned as the three RGB components of the color. RGB values are in the range of 0~65535.

PROCEDURE GetClFillBack(
className :STRING;
VAR colorRV :LONGINT;
VAR colorGV :LONGINT;
VAR colorBV :LONGINT);
def vs.GetClFillBack(className):
    return (colorRV, colorGV, colorBV)

Parameters

className STRING Name of class.
colorRV LONGINT Returns RGB color component (red).
colorGV LONGINT Returns RGB color component (green).
colorBV LONGINT Returns RGB color component (blue).

Remarks

Returns the fill background color setting of the class named className in parameters colorRV, colorGV, and colorBV.

Example

VectorScript

PROCEDURE Example;
VAR
   cRed, cGrn, cBlu : LONGINT;
   colorValue : INTEGER;
BEGIN
  GetClFillBack('Grassy Cover',cRed,cGrn,cBlu);
  RGBToColorIndex(cRed,cGrn,cBlu,colorValue);
  Message(colorValue);
END;
RUN(Example);

Python

Python


Version

Availability: from VectorWorks8.0