VS:GetClFPat

From Vectorworks Developer
Revision as of 19:53, 19 June 2014 by Maziar (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fill or hatch pattern of the specified class.

A positive return value in a range of 0 to 71 is the index of the bitmap fill pattern of the class. A negative value is the negative of the fill pattern index (index * -1).

Fill patterns and their associated constants can be found in the Function Reference Appendix.

FUNCTION GetClFPat(
className :STRING) : LONGINT;
def vs.GetClFPat(className):
    return LONGINT

Parameters

className STRING Name of class.

Remarks

Returns the fill pattern of the class named className.

Example

VectorScript

PROCEDURE Example;
BEGIN
Message(GetClFPat('Dimension'));
END;
RUN(Example);

Python

def Example():
	vs.Message(vs.GetClFPat('Dimension'));
Example();

Version

Availability: from VectorWorks8.0