VS:GetClFPat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(3 intermediate revisions by 2 users not shown)
Line 42: Line 42:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
==== VectorScript ====
<code lang="pas">
<code lang="pas">
pbFillStyl:= GetClFPat('Grassy Cover');</code>
PROCEDURE Example;
BEGIN
Message(GetClFPat('Dimension'));
END;
RUN(Example);
</code>
==== Python ====
<code lang="py">
def Example():
vs.Message(vs.GetClFPat('Dimension'));
Example();
</code>
</sample>
</sample>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>

Latest revision as of 19:53, 19 June 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fill or hatch pattern of the specified class.

A positive return value in a range of 0 to 71 is the index of the bitmap fill pattern of the class. A negative value is the negative of the fill pattern index (index * -1).

Fill patterns and their associated constants can be found in the Function Reference Appendix.

FUNCTION GetClFPat(
className :STRING) : LONGINT;
def vs.GetClFPat(className):
    return LONGINT

Parameters

className STRING Name of class.

Remarks

Returns the fill pattern of the class named className.

Example

VectorScript

PROCEDURE Example;
BEGIN
Message(GetClFPat('Dimension'));
END;
RUN(Example);

Python

def Example():
	vs.Message(vs.GetClFPat('Dimension'));
Example();

Version

Availability: from VectorWorks8.0