VS:GetChoiceStringFromStoryBoundData

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the story bound choice string from story bound data.

PROCEDURE GetChoiceStringFromStoryBoundData(
boundType :INTEGER;
boundStory :INTEGER;
layerLevelType :STRING;
VAR choiceString :STRING);
def vs.GetChoiceStringFromStoryBoundData(boundType, boundStory, layerLevelType):
    return choiceString

Parameters

boundType INTEGER Bounding type: 0 - DefaultWallHeight; 1 - LayerZ; 2 - Story.
boundStory INTEGER The story identified by 'boundType' = (2 - Story). If 'boundStory' = 0 then it is this story (the object's story); If 'boundStory' = 1 then it is the story above; If 'boundStory' = 2 then it is the story below.
layerLevelType STRING The layer type which defines this bound.
choiceString STRING Returns the choice string that represents the story bound data.

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetStoryBoundChoiceStrings | VS:GetStoryBoundDataFromChoiceString

VS Functions:

[[VS:GetStoryBoundChoiceStrings]]

| [[VS:GetStoryBoundDataFromChoiceString]]