VS:GetChoiceStr

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

GetChoiceStr returns the string associated with a particular choice item value.

PROCEDURE GetChoiceStr(
item :INTEGER;
whichChoice :INTEGER;
VAR s :STRING);
def vs.GetChoiceStr(item, whichChoice):
    return s

Parameters

item INTEGER Item ID of dialog control.
whichChoice INTEGER Position of choice item in list (in a range of 0 - n).
s STRING Returns string value associated with position in list.

Remarks

Note: deprecated from VW 15+, use GetChoiceText

Returns the string associated with a particular combo box value. Pass the dialog item number and the index of the value for which you want the string

Example

VectorScript

GetChoiceStr(7,1,returnStr);

Python


Version

Availability: from VectorWorks 8.0. Deprecated from VW 15+.

See Also

VS Functions:

VS:GetSelChoice

VS Functions: [[VS:GetSelChoice]]