VS:GetChoiceIndex

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Finds the index of the given string in a layout manager list box or pull down menu. The index is zero based and is set to -1 if the item is not found.

PROCEDURE GetChoiceIndex(
dialogID :LONGINT;
componentID :LONGINT;
itemText :STRING;
VAR itemIndex :INTEGER);
def vs.GetChoiceIndex(dialogID, componentID, itemText):
    return itemIndex

Parameters

dialogID LONGINT
componentID LONGINT
itemText STRING
itemIndex INTEGER

Version

Availability: from Vectorworks 2012