VS:GetCatalogPath

From Vectorworks Developer
Revision as of 19:25, 12 September 2017 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the path to catalog files for a plug-in object.

FUNCTION GetCatalogPath(
inhObject :HANDLE;
VAR outFolderSpec :INTEGER;
VAR outRelativePath :STRING) : BOOLEAN;
def vs.GetCatalogPath(inhObject):
    return (BOOLEAN, outFolderSpec, outRelativePath)

Parameters

inhObject HANDLE Handle of parametric object.
outFolderSpec INTEGER Returns the Folder Specificer of the catalogs.
outRelativePath STRING Returns the relative path to the folder specficier. May be empty.

Return Value

TRUE of the object supports catalogs.

FALSE if the object does not support catalogs.

Version

Availability: from Vectorworks 2018