VS:GetCWPanelFromPt/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

カーテンウォールの指定した点にあるパネルに関する情報を返します。
カーテンウォールのパネルの中にオブジェクトを配置するために使用します。壁の中のオブジェクトの中心点を渡すと、カーテンウォールのパネルを探し出し、パネルの中心点、高さ、幅を返します。

FUNCTION GetCWPanelFromPt(
hWall :HANDLE;
testPt :REAL;
includeBottomFrame :BOOLEAN;
VAR centerPt :REAL;
VAR width :REAL;
VAR height :REAL) : BOOLEAN;
def vs.GetCWPanelFromPt(hWall, testPt, includeBottomFrame):
    return (BOOLEAN, centerPt, width, height)

Parameters

hWall HANDLE カーテンウォールのハンドル
testPt REAL カーテンウォール中の探索点。典型的には、カーテンウォールのパネルに入れるオブジェクトの中心点。
includeBottomFrame BOOLEAN 返値の高さに下枠を含む。
centerPt REAL オブジェクトを配置する長方形の中心点を返します。
width REAL オブジェクトを配置する長方形の幅。
height REAL オブジェクトを配置する長方形の高さ。

Return Value

hWallがカーテンウォールでパネルが見つかった場合TRUEを返します。
hWallがカーテンウォールでないか、点が壁の中になかった場合にFALSEを返します。

Version

利用可能バージョン: Vectorworks 2014