VS:GetCWPanelFromPt

From Vectorworks Developer
Revision as of 13:49, 26 January 2015 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns information about a panel in a crutain wall from a given point.


Used for placing objects inside a panel in a curtain wall. When passing the center point of the object in the wall, it will find the panel in the curtain wall and return a new center point and the height and width of the panel.

FUNCTION GetCWPanelFromPt(
hWall :HANDLE;
testPt :REAL;
includeBottomFrame :BOOLEAN;
VAR centerPt :REAL;
VAR width :REAL;
VAR height :REAL) : BOOLEAN;
def vs.GetCWPanelFromPt(hWall, testPt, includeBottomFrame):
    return (BOOLEAN, centerPt, width, height)

Parameters

hWall HANDLE Handle to the curtain wall
testPt REAL Point to test on the curtian wall. Typically the center point of the object to be placed in the curtian wall panel.
includeBottomFrame BOOLEAN Include the bottom frame in the return height.
centerPt REAL Returns the center point of the rectangle in witch to place the object.
width REAL The width of the rectangle in which to place the object.
height REAL The height of the rectangle in which to place the object.

Return Value

Returns TRUE if hWall is a crutain wall and a panel is found.

Returns FALSE is hWall is not a curtiain wall or the test point is not found on the wall.

Version

Availability: from Vectorworks 2014