VS:GetCWPanelFromPt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(fix typos)
No edit summary
 
Line 13: Line 13:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetCWPanelFromPt(hWall:HANDLE; testPt:REAL; includeBottomFrame:BOOLEAN; VAR centerPt:REAL; VAR width:REAL; VAR height:REAL) : BOOLEAN;
FUNCTION GetCWPanelFromPt(hWall:HANDLE; testPt:POINT; includeBottomFrame:BOOLEAN; VAR centerPt:POINT; VAR width:REAL; VAR height:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 31: Line 31:
<line>
<line>
testPt
testPt
REAL
POINT
Point to test on the curtain wall. Typically the center point of the object to be placed in the curtain wall panel.
Point to test on the curtain wall. Typically the center point of the object to be placed in the curtain wall panel.
</line>
</line>
Line 41: Line 41:
<line>
<line>
centerPt
centerPt
REAL
POINT
Returns the center point of the rectangle in witch to place the object.  
Returns the center point of the rectangle in witch to place the object.  
</line>
</line>

Latest revision as of 15:24, 18 July 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns information about a panel in a curtain wall from a given point.


Used for placing objects inside a panel in a curtain wall. When passing the center point of the object in the wall, it will find the panel in the curtain wall and return a new center point and the height and width of the panel.

FUNCTION GetCWPanelFromPt(
hWall :HANDLE;
testPt :POINT;
includeBottomFrame :BOOLEAN;
VAR centerPt :POINT;
VAR width :REAL;
VAR height :REAL) : BOOLEAN;
def vs.GetCWPanelFromPt(hWall, testPt, includeBottomFrame):
    return (BOOLEAN, centerPt, width, height)

Parameters

hWall HANDLE Handle to the curtain wall
testPt POINT Point to test on the curtain wall. Typically the center point of the object to be placed in the curtain wall panel.
includeBottomFrame BOOLEAN Include the bottom frame in the return height.
centerPt POINT Returns the center point of the rectangle in witch to place the object.
width REAL The width of the rectangle in which to place the object.
height REAL The height of the rectangle in which to place the object.

Return Value

Returns TRUE if hWall is a curtain wall and a panel is found.

Returns FALSE is hWall is not a curtain wall or the test point is not found on the wall.

Version

Availability: from Vectorworks 2014