VS:GetCWFramesFromPt

From Vectorworks Developer
Revision as of 13:49, 26 January 2015 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns information about the frames in a crutain wall from a given point.


Used for placing objects inside a panel in a curtain wall. When passing the center point of the object in the wall, it will find the panel in the curtain wall and return information about the surrouding frames.

FUNCTION GetCWFramesFromPt(
hWall :HANDLE;
testPt :REAL;
includeBottomFrame :BOOLEAN;
VAR panelThickness :REAL;
VAR panelOffset :REAL;
VAR frameInsetTop :REAL;
VAR frameInsetBottom :REAL;
VAR frameInsetRight :REAL;
VAR frameInsetLeft :REAL) : BOOLEAN;
def vs.GetCWFramesFromPt(hWall, testPt, includeBottomFrame):
    return (BOOLEAN, panelThickness, panelOffset, frameInsetTop, frameInsetBottom, frameInsetRight, frameInsetLeft)

Parameters

hWall HANDLE Handle to the curtain wall
testPt REAL Point to test on the curtian wall. Typically the center point of the object to be placed in the curtian wall panel.
includeBottomFrame BOOLEAN Include the bottom frame.
panelThickness REAL This is the thickness of the panel as it subtracts from the frames. It is a property of the panel
panelOffset REAL This is the dimension from the center of the panel to the center of the wall
frameInsetTop REAL The frame inset is the distance the panel extends into and subtracts from the frame.
frameInsetBottom REAL
frameInsetRight REAL
frameInsetLeft REAL

Return Value

Returns TRUE if hWall is a crutain wall and frames are found.

Returns FALSE is hWall is not a curtiain wall or the test point is not found on the wall.

Version

Availability: from Vectorworks 2015