VS:GetCWFramesFromPt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns information about the frames  in a crutain wall from a given point.<BR>
Returns information about the frames  in a curtain wall from a given point.<BR>
<BR>
<BR>
Used for placing objects inside a panel in a curtain wall. When passing the center point of the object in the wall, it will find the panel in the curtain wall and return information about the surrouding frames.</desc>
Used for placing objects inside a panel in a curtain wall. When passing the center point of the object in the wall, it will find the panel in the curtain wall and return information about the surrouding frames.</desc>
Line 13: Line 13:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetCWFramesFromPt(hWall:HANDLE; testPt:REAL; includeBottomFrame:BOOLEAN; VAR panelThickness:REAL; VAR panelOffset:REAL; VAR frameInsetTop:REAL; VAR frameInsetBottom:REAL; VAR frameInsetRight:REAL; VAR frameInsetLeft:REAL) : BOOLEAN;
FUNCTION GetCWFramesFromPt(hWall:HANDLE; testPt:POINT; includeBottomFrame:BOOLEAN; VAR panelThickness:REAL; VAR panelOffset:REAL; VAR frameInsetTop:REAL; VAR frameInsetBottom:REAL; VAR frameInsetRight:REAL; VAR frameInsetLeft:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 31: Line 31:
<line>
<line>
testPt
testPt
REAL
POINT
Point to test on the curtian wall. Typically the center point of the object to be placed in the curtian wall panel.
Point to test on the curtain wall. Typically the center point of the object to be placed in the curtain wall panel.
</line>
</line>
<line>
<line>
Line 74: Line 74:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
Returns TRUE if hWall is a crutain wall and frames are found.<BR>
Returns TRUE if hWall is a curtain wall and frames are found.<BR>
Returns FALSE is hWall is not a curtiain wall or the test point is not found on the wall.</return>
Returns FALSE is hWall is not a curtain wall or the test point is not found on the wall.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 15:21, 18 July 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns information about the frames in a curtain wall from a given point.


Used for placing objects inside a panel in a curtain wall. When passing the center point of the object in the wall, it will find the panel in the curtain wall and return information about the surrouding frames.

FUNCTION GetCWFramesFromPt(
hWall :HANDLE;
testPt :POINT;
includeBottomFrame :BOOLEAN;
VAR panelThickness :REAL;
VAR panelOffset :REAL;
VAR frameInsetTop :REAL;
VAR frameInsetBottom :REAL;
VAR frameInsetRight :REAL;
VAR frameInsetLeft :REAL) : BOOLEAN;
def vs.GetCWFramesFromPt(hWall, testPt, includeBottomFrame):
    return (BOOLEAN, panelThickness, panelOffset, frameInsetTop, frameInsetBottom, frameInsetRight, frameInsetLeft)

Parameters

hWall HANDLE Handle to the curtain wall
testPt POINT Point to test on the curtain wall. Typically the center point of the object to be placed in the curtain wall panel.
includeBottomFrame BOOLEAN Include the bottom frame.
panelThickness REAL This is the thickness of the panel as it subtracts from the frames. It is a property of the panel
panelOffset REAL This is the dimension from the center of the panel to the center of the wall
frameInsetTop REAL The frame inset is the distance the panel extends into and subtracts from the frame.
frameInsetBottom REAL
frameInsetRight REAL
frameInsetLeft REAL

Return Value

Returns TRUE if hWall is a curtain wall and frames are found.

Returns FALSE is hWall is not a curtain wall or the test point is not found on the wall.

Version

Availability: from Vectorworks 2015