VS:GetCVis

From Vectorworks Developer
Revision as of 21:39, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the visibility status of the specified class.

FUNCTION GetCVis(
className :STRING) : INTEGER;
def vs.GetCVis(className):
    return INTEGER

Parameters

className STRING Name of class.

Return Value

Returns one of:

Visibility Index Value
Visible 0
Hidden -1
Grayed 2

Remarks

Also, though a warning is generated, passing a string to a non-existent class returns 0.

Example

PROCEDURE Example;
BEGIN
Message(GetCVis('Dimension'));
END;
RUN(Example);

Version

Availability: from All Versions