VS:GetBBox

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetBBox returns the bounding box of the projection of the referenced object on the screen plane.

PROCEDURE GetBBox(
h :HANDLE;
VAR p1X,p1Y :REAL;
VAR p2X,p2Y :REAL);
def vs.GetBBox(h):
    return (p1, p2)

Parameters

h HANDLE Handle to object.
p1 REAL Top left coordinate of bounding box.
p2 REAL Bottom right coordinate of bounding box.

Remarks

_c_, 2017.02.24: GetBBox fails unpredictably on Roof faces when in top-plan: it returns a bounding box dependent on the axis widget and the page position of the face. Avoid the axis widget setting the view to Top, then the returned values will be correct. This is valid up to VW 2017 (bug reported).

Version

Availability: from All Versions