VS:GetActivePane/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

現在表示されているタブかスワップパネルを返します。


イベントハンドリングルーチンで使います。

FUNCTION GetActivePane(
dialogID :LONGINT;
tabControlID :LONGINT) : LONGINT;
def vs.GetActivePane(dialogID, tabControlID):
    return LONGINT

Parameters

dialogID LONGINT ダイアログ番号
tabControlID LONGINT コントロール番号

Example

Procedure DialogProc(VAR item: LONGINT; data: LONGINT);
BEGIN
	CASE item OF
		SetupDialogC:
		BEGIN
			result := 0;
		END;

		100:	DisplaySwapPane(dlogID, 10, 1);  { Display pane 1 }
		101:	DisplaySwapPane(dlogID, 10, 2);  { Display pane 2 }
		102:	DisplaySwapPane(dlogID, 10, 3);  { Display pane 3 }

	END;
END;

Version

利用可能バージョン: VectorWorks12.0

See Also

関連関数:

VS:CreateSwapControl | VS:CreateSwapPane

関連関数:

[[VS:CreateSwapControl]]

| [[VS:CreateSwapPane]]